フィルタベースフォワーディング

フィルタベースフォワーディング

フィルタベースフォワーディングとは

ルーティングテーブルに採用されている経路情報以外の転送先にパケットを送り出すことが可能です.JUNOSのファイアウォールフィルターを使用して条件にマッチングしたパケットを転送することができます.

FBF.png

R1でデフォルトルートのネクストホップが192.168.20.2であるルーティングインスタンスを作成します.

set routing-instances INSTANCE-FBF instance-type forwarding
set routing-instances INSTANCE-FBF routing-options static route 0.0.0.0/0 next-hop 192.168.20.2

ポリシーオプションでパケットを転送処理するインタフェースem0を定義します.

set policy-options policy-statement POLICY-FBF term 1 from interface em0
set policy-options policy-statement POLICY-FBF term 1 then accept
set policy-options policy-statement POLICY-FBF term 2 then reject

RIBに対してデフォルトのルーティングインスタンスとINSTANCE-FBFをインポートします.ポリシーもここでインポートします.

set routing-options interface-routes rib-group inet FBF
set routing-options rib-groups FBF import-rib inet.0
set routing-options rib-groups FBF import-rib INSTANCE-FBF.inet.0
set routing-options rib-groups FBF import-policy POLICY-FBF

ファイアウォールフィルターの定義をします.送信元IPアドレスが5.5.5.5/32の場合に作成したルーティングインスタンスが処理されるように設定します.

set firewall family inet filter FILTER-FBF term 1 from source-address 5.5.5.5/32
set firewall family inet filter FILTER-FBF term 1 then routing-INSTANCE INSTANCE-FBF
set firewall family inet filter FILTER-FBF term 2 then accept

フィルターをインタフェースに適用します.

set interfaces em0 unit 0 family inet filter input FILTER-FBF